Libby and OverDrive System Requirements

Recent update to system requirements for Libby and Overdrive

As of October 1st, 2021, OverDrive reported that the web certificate provider Let's Encrypt would end support for older operating systems and browsers. Certificates from Let's Encrypt are relied on for secure connections for websites and apps including Libby and OverDrive.  As a result of this change, the following is now in effect:

  • Libby's minimum iOS version is now iOS 12.  To use Libby on an iOS device, users are required to update their device's operating system to iOS 12 or newer, if possible.  Support from the Apple website posted steps to help iOS users update their operating system version

  • The legacy OverDrive for the Mac desktop app is only supported on macOS versions 10.12.1 through 10.14.
    If you update to macOS 10.15 or higher, you'll lose access to Overdrive for Mac.

  • Users on legacy web browsers may experience issues with loading or the Bridges website and should upgrade to a newer browser, if possible.

The expectation was that affected users would receive a security warning after the Let's Encrypt change, but we've since learned that a warning is not always displayed.  Users may experience issues with signing in, borrowing, loading the app's content, etc.